DrawingCreatorCreateDrawings Method (AutoDrawingRule, ListIdentifier, AutoDrawingsStatusEnum)

Creates drawings using the AutoDrawing tool of Tekla Structures.

Namespace:  Tekla.Structures.Drawing.Automation
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static bool CreateDrawings(
	AutoDrawingRule Rule,
	List<Identifier> aModelObjectIdentifier,
	out AutoDrawingsStatusEnum OperationStatus
)

Parameters

Rule
Type: Tekla.Structures.Drawing.AutomationAutoDrawingRule
The AutoDrawing rule to be used.
aModelObjectIdentifier
Type: System.Collections.GenericListIdentifier
The model object identifier list to be used. Part identifiers to create single part drawings or assembly identifiers to create assembly drawings.
OperationStatus
Type: Tekla.Structures.Drawing.AutomationAutoDrawingsStatusEnum
The operation status to be used.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next