CatalogHandlerImportCustomComponentItems Method

Imports custom component items (*.uel) from path to component catalog. Import overrides the existing custom components in the catalog without any warnings.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool ImportCustomComponentItems(
	string path
)

Parameters

path
Type: SystemString
The path to be used for import. This can be a uel file or a folder containing one or more uel files.

Return Value

Type: Boolean
true if successful.
Examples
using System;
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           if (new CatalogHandler().ImportCustomComponentItems(System.IO.Path.GetTempPath()))
               Console.WriteLine("Custom components imported successfully to catalog.");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next