ApplicationWindowBase Class

The ApplicationWindowBase class is the base class for all Tekla Structures WPF dialogs. The class provides localization, unit conversion and data storage (temporary and file-based) among other things.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class ApplicationWindowBase : WindowBase

The ApplicationWindowBase type exposes the following members.

Constructors
  NameDescription
Public methodApplicationWindowBase
The default constructor that does not need parameters. Initializes the window, property binding can be initialized with InitializeDataStorage()-method.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Public methodInitializeDataStorage
Initializes the datastorage and registers property bindings for defined viewmodel.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next