ApplicationWindowBase Class

The ApplicationWindowBase class is the base class for all Tekla Structures WPF dialogs. The class provides localization, unit conversion and data storage (temporary and file-based) among other things.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class ApplicationWindowBase : WindowBase

The ApplicationWindowBase type exposes the following members.

Constructors
  NameDescription
Public methodApplicationWindowBase
The default constructor that does not need parameters. Initializes the window, property binding can be initialized with InitializeDataStorage()-method.
Top
Properties
  NameDescription
Public propertyLocalization
The localization instance for the dialog. Each dialog has its own localization instance that has read the localization files needed for that dialog.
(Inherited from WindowBase.)
Public propertyLocExtension
The localization instance for the dialog. Each dialog has its own localization instance that has read the localization files needed for that dialog.
(Inherited from WindowBase.)
Public propertyUseDefaultStyle
Use default style in all the window controls or not. If the property is not set in the window constructor the default value (true) is used.
(Inherited from WindowBase.)
Top
Methods
  NameDescription
Public methodApplyValues
Loads the dialog values from a file and performs Apply on the loaded values. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.)
Public methodGetConnectionStatus
Returns true if a proper connection to the Tekla Structures process has been established. Currently, there's no way to re-establish the connection.
(Inherited from WindowBase.)
Public methodInitializeDataStorage
Initializes the datastorage and registers property bindings for defined viewmodel.
Public methodInitializeWindow
Prepares the data storage for the dialog and scans through the fields.
(Inherited from WindowBase.)
Public methodLoadValues
Loads the dialog values from a file. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.)
Public methodModifyValues
Loads the dialog values from a file and performs Modify on the loaded values. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.)
Public methodSaveValues
Serializes the dialog values to an xml file.
(Inherited from WindowBase.)
Public methodShowWindow
Displays the window.
(Inherited from WindowBase.)
Public methodUpdateDataStorageFromViewModel
DO NOT USE! For internal usage only!
(Inherited from WindowBase.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next