ReinforcementGetRebarGeometries Method (ReinforcementRebarGeometryOptionEnum)

Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ArrayList GetRebarGeometries(
	ReinforcementRebarGeometryOptionEnum options
)

Parameters

options
Type: Tekla.Structures.ModelReinforcementRebarGeometryOptionEnum
The options.

Return Value

Type: ArrayList
An array list that contains the RebarGeometry objects.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next