ConnectiveGeometryException Class

The ConnectiveGeometryException class represents an error that occurred during the ConnectiveGeometry creation or modification.
Inheritance Hierarchy
SystemObject
  SystemException
    Tekla.Structures.ModelConnectiveGeometryException
      More...

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class ConnectiveGeometryException : Exception

The ConnectiveGeometryException type exposes the following members.

Constructors
  NameDescription
Public methodConnectiveGeometryException
Initializes a new instance of the ConnectiveGeometryException class with general connective geometry error message.
Public methodConnectiveGeometryException(BentPlateGeometrySolverOperationStatus, String)
Initializes a new instance of the ConnectiveGeometryException class with connective geometry error message based on status.
Top
Fields
  NameDescription
Public fieldOperationStatus
Possible error statuses for geometry creation/modification commands.
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemException
    Tekla.Structures.ModelConnectiveGeometryException
      Tekla.Structures.ModelExtensionIntersectsWithPlateException
      Tekla.Structures.ModelFacePerpendicularToIntersectionLineException
      Tekla.Structures.ModelFacesAtAnObtuseAngleException
      Tekla.Structures.ModelFacesTooNearEachOtherException
      Tekla.Structures.ModelGeneralConnectiveGeometryException
      Tekla.Structures.ModelInvalidFacePointsException
      Tekla.Structures.ModelInvalidRadiusException
      Tekla.Structures.ModelPlateIntersectsWithIntersectionLineException
      Tekla.Structures.ModelUndefinedCurveDirectionException
      Tekla.Structures.ModelUnsupportedChamferException
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next