Tekla.Structures.Model.Collaboration Namespace

The Tekla.Structures.Model.Collaboration namespace contains some extra functionality to get information about IFC reference model objects. This functionality is not really a part of the Tekla product model and might change in the near future.
Classes
  ClassDescription
Public classIFC2X3_ParametricObject_CircleHollowProfile
The IFC2X3_ParametricObject_CircleHollowProfile class contains the circular and hollow profile definition.
Public classIFC2X3_ParametricObject_CircleProfile
The IFC2X3_ParametricObject_CircleProfile class contains the circular profile definition.
Public classIFC2X3_ParametricObject_CShapeProfile
The IFC2X3_ParametricObject_CShapeProfile class contains the C-shape profile definition.
Public classIFC2X3_ParametricObject_EllipseProfile
The IFC2X3_ParametricObject_EllipseProfile class contains the ellipse profile definition.
Public classIFC2X3_ParametricObject_IShapeProfile
The IFC2X3_ParametricObject_IShapeProfile class contains the I-shape profile definition.
Public classIFC2X3_ParametricObject_LShapeProfile
The IFC2X3_ParametricObject_LShapeProfile class contains the L-shape profile definition.
Public classIFC2X3_ParametricObject_RectangleHollowProfile
The IFC2X3_ParametricObject_RectangleHollowProfile class contains the rectangular and hollow profile definition.
Public classIFC2X3_ParametricObject_RectangleProfile
The IFC2X3_ParametricObject_RectangleProfile class contains the rectangular profile definition.
Public classIFC2X3_ParametricObject_TShapeProfile
The IFC2X3_ParametricObject_TShapeProfile class contains the T-shape profile definition.
Public classIFC2X3_ParametricObject_UShapeProfile
The IFC2X3_ParametricObject_UShapeProfile class contains the U-shape profile definition.
Public classIFC2X3_ParametricObject_ZShapeProfile
The IFC2X3_ParametricObject_ZShapeProfile class contains the Z-shape profile definition.
Public classParametricObject_CustomProfile
The ParametricObject_CustomProfile class contains the custom profile definition.
Public classParametricObject_ObjectBoundingBox
The ParametricObject_ObjectBoundingBox class contains the object bounding box (OBB) definition.
Public classReferenceModelObjectAttribute
The ReferenceModelObjectAttribute class is a base class from where concrete attributes are derived from. The documentation about different attributes and their function can be found from the vendor specification, for example from the IFC format specification.
Public classCode exampleReferenceModelObjectAttributeEnumerator
The ReferenceModelObjectAttributeEnumerator class can be used to enumerate through reference model object attributes.
Enumerations
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next