SecondaryTypeAttribute Class

The SecondaryTypeAttribute class is used for storing the number of needed secondaries in the connection. Based on the type the system can then correctly ask for user input in the creation. The attribute is initialized from the custom attribute i.e. [SecondaryType(ConnectionBase.SecondaryType.SECONDARYTYPE_ONE)] in the connection source.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsSecondaryTypeAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class SecondaryTypeAttribute : Attribute

The SecondaryTypeAttribute type exposes the following members.

Constructors
  NameDescription
Public methodSecondaryTypeAttribute(Int32)
The custom attribute [SecondaryType()] uses this to store the secondary type to the system. This is not to be used by itself.
Public methodSecondaryTypeAttribute(ConnectionBaseSecondaryType)
The custom attribute [SecondaryType()] uses this to store the secondary type to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
The custom attribute [SecondaryType()] uses this to store the secondary type to the system. This is not to be used by itself.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next