OBBShortestSegmentTo Method (Line)

Calculates the shortest LineSegment from OBB to the given Line.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public LineSegment ShortestSegmentTo(
	Line line
)

Parameters

line
Type: Tekla.Structures.Geometry3dLine
Line to calculate against

Return Value

Type: LineSegment
Shortest LineSegment from OBB to the given Line.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the line parameter.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next