GeometryConstants Class

The Constants class of Geometry3d holds certain constant values that are used internally by the other geometry classes.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dGeometryConstants

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class GeometryConstants

The GeometryConstants type exposes the following members.

Constructors
  NameDescription
Public methodGeometryConstants
Initializes a new instance of the GeometryConstants class
Top
Fields
  NameDescription
Public fieldStatic memberANGULAR_EPSILON
The minimum angle (radians) used for checking angular parallelism, perpendicularity, etc. Anything smaller will be considered equivalent to 0.0.
Public fieldStatic memberDISTANCE_EPSILON
The minimum distance used for checking if points, lines, etc. coincide. Anything smaller will be considered equivalent to 0.0.
Public fieldStatic memberSCALAR_EPSILON
The minimum value used for comparing floating point scalar values. Any smaller difference will be considered equivalent to 0.0.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next