StructuresExtender Class

The StructuresExtender class is for binding controls to datatypes. The bindings are needed to transfer the dialog values to Tekla Structures and onwards to plug-ins.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class StructuresExtender : Component, 
	IExtenderProvider

The StructuresExtender type exposes the following members.

Constructors
  NameDescription
Public methodStructuresExtender
Initializes a new instance of the StructuresExtender class
Top
Methods
  NameDescription
Public methodCanExtend
Specifies whether the current object can provide its extender properties to the specified object.
Public methodGetAttributeName
Retrieves the AttributeName text associated with the specified control.
Public methodGetAttributeTypeName
Retrieves the AttributeTypeName text associated with the specified control.
Public methodGetBindPropertyName
Retrieves the BindPropertyName text associated with the specified control.
Public methodGetIsFilter
Retrieves the IsFilter boolean value associated with the specified control.
Public methodSetAttributeName
Associates AttributeName text with the specified control.
Public methodSetAttributeTypeName
Associates the AttributeTypeName text with the specified control.
Public methodSetBindPropertyName
Associates the BindPropertyName text with the specified control.
Public methodSetIsFilter
Associates the IsFilter boolean value with the specified control.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next