DrawingItemEnumerator Class

The DrawingItemEnumerator class allows to loop through the catalog drawing items.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsDrawingItemEnumerator

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class DrawingItemEnumerator : IEnumerator

The DrawingItemEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Returns a drawing item instance of the current element.
Top
Methods
  NameDescription
Public methodGetSize
Returns the total amout of items.
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodReset
Resets the enumerator to the beginning.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next