SurfacingSurfacingAttributes Class

The SurfacingAttributes class is the attributes class for the surfacing.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingSurfacingSurfacingAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class SurfacingAttributes : AttributesBase

The SurfacingSurfacingAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyDrawHiddenLines
True if hidden lines are drawn.
Public propertyDrawOwnHiddenLines
True if own hidden lines are enabled.
Public propertyHiddenLines
The line type of hidden lines.
Public propertyRepresentation
The representation type of the surfacing.
Public propertyShowPattern
True if the pattern is shown.
Public propertyVisibleLines
The line type of visible lines.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next