Polygon Class

The Polygon class represents a polygon object that has its corners at the given points.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelPolygon

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Polygon

The Polygon type exposes the following members.

Constructors
  NameDescription
Public methodPolygon
Initializes a new polygon instance with empty attributes.
Top
Properties
  NameDescription
Public propertyPoints
The corners of the polygon.
Top
Fields
  NameDescription
Public fieldStatic memberMAX_POLYGON_POINTS
The maximum number of polygon points that is typically valid in Tekla Structures.
Public fieldStatic memberMIN_POLYGON_POINTS
The minimum number of polygon points that is typically valid in Tekla Structures.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next