AnalysisObjectEnumerator Class

The AnalysisObjectEnumerator class provides the means to iterate through analysis object instances.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisObjectEnumerator

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class AnalysisObjectEnumerator : IEnumerator

The AnalysisObjectEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Gets the current analysis object in the enumerator.
Public propertyCurrentItem
Gets or sets the index of the current item.
Public propertyCurrentSelected
Gets or sets the currently selected item.
Public propertySelectInstances
Gets or sets a value indicating whether the instance's Select() is called when the "Current" item is asked from the enumerator. The user can set this to "false" if no members are ever asked from the instance. This is the case when e.g. asking only a report property from this identifier. WARNING: normally the user should not change this value.
Top
Methods
  NameDescription
Public methodGetEnumerator
Returns a pointer to the existing instance of the class. This allows the usage of the foreach statement with AnalysisObjectEnumerator.
Public methodGetSize
Returns the total amout of items.
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodRefresh
Refreshes the enumerator with latest data at database.
Public methodReset
Resets the enumerator to the beginning.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next