SectionMarkBaseSectionMarkTagAttributes Constructor (SectionMarkBaseSectionMarkTagAttributesTagShowOnSide, TagLocation, Vector, SectionMarkBaseSectionMarkTagAttributesTagTextRotation, ContainerElement)

Creates a new section mark tag attributes instance with the given information.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public SectionMarkTagAttributes(
	SectionMarkBaseSectionMarkTagAttributesTagShowOnSide showOnSide,
	TagLocation location,
	Vector offset,
	SectionMarkBaseSectionMarkTagAttributesTagTextRotation rotation,
	ContainerElement tagContent
)

Parameters

showOnSide
Type: Tekla.Structures.DrawingSectionMarkBaseSectionMarkTagAttributesTagShowOnSide
The side(s) on which to show the tag to be used.
location
Type: Tekla.Structures.DrawingTagLocation
The location of the mark tag to be used.
offset
Type: Tekla.Structures.Geometry3dVector
The offset of the mark tag to be used.
rotation
Type: Tekla.Structures.DrawingSectionMarkBaseSectionMarkTagAttributesTagTextRotation
The policy for text rotation of the mark tag to be used.
tagContent
Type: Tekla.Structures.DrawingContainerElement
The content of the mark tag to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next