MaterialItem Class

The MaterialItem class contains information about the materials in the Tekla Structures catalog.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsMaterialItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class MaterialItem

The MaterialItem type exposes the following members.

Constructors
  NameDescription
Public methodMaterialItem
Creates a new material item instance.
Top
Properties
  NameDescription
Public propertyAliasName1
The material item's alias name 1.
Public propertyAliasName2
The material item's alias name 2.
Public propertyAliasName3
The material item's alias name 3.
Public propertyDesignCode
The design code.
Public propertyMaterialName
The material item's name.
Public propertyModulusOfElasticity
Thte modulus of elasticity in unit N/m2.
Public propertyPlateDensity
The plate density in unit kg/m3.
Public propertyPoissonsRatio
The poissons ratio
Public propertyProfileDensity
The profile density in unit kg/m3.
Public propertyThermalDilatation
The thermal dilatation in unit 1/K.
Public propertyType
The material item's type.
Top
Methods
  NameDescription
Public methodDelete
Delete this material from material database.
Public methodCode exampleExport
Exports the material item in the material database to given file name. Materials are exported to *.lis format. If path is not given material is exported to model folder. If filename is empty material name is used as filename.
Public methodInsert
Inserts this material item to material database.
Public methodStatic memberMaterialNameMaxLength
Returns the maximum length a material name can be.
Public methodModify
Modifies the material in material database that has the same name as this instance.
Public methodSelect
Selects the material item from the database based on the material name and alias name in this instance.
Public methodSelect(String)
Selects the material item based on the name from the material database. The material name can also be an alias name.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next