OperationSplit Method (Beam, Point)

Splits the beam and creates a new one in the given position.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public static Beam Split(
	Beam Object,
	Point SplitPoint
)

Parameters

Object
Type: Tekla.Structures.ModelBeam
The beam object to be split.
SplitPoint
Type: Tekla.Structures.Geometry3dPoint
The position where splitting is executed.

Return Value

Type: Beam
The created beam on success, null on failure.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next