AlongLinePlacing Class

The AlongLinePlacing class defines a placing where the object is located and moved along a line defined by two points.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class AlongLinePlacing : PlacingBase

The AlongLinePlacing type exposes the following members.

Constructors
  NameDescription
Public methodAlongLinePlacing
Creates a new along line placing instance. The given two points define the line to be used for the placing.
Top
Properties
  NameDescription
Public propertyEndPoint
The end point of the line that the object is placed on.
Public propertyStartPoint
The start point of the line that the object is placed on.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PlacingBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next