Line Class

The Line class represents a single infinite line in 3D space. See LineSegment for the implementation of a segment of a line.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dLine

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Line

The Line type exposes the following members.

Constructors
  NameDescription
Public methodLine
Instantiates a line with an undefined direction.
Public methodLine(LineSegment)
Instantiates a line defined by the given line segment.
Public methodLine(Point, Point)
Instantiates a line defined by the given points.
Public methodLine(Point, Vector)
Instantiates a line defined by the given point and direction vector.
Top
Properties
  NameDescription
Public propertyDirection
The direction vector of the line.
Public propertyOrigin
The origin of the line.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next