BentPlateGeometrySolverSetMainSection Method

Sets newMainSection as a main section of geometry.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ConnectiveGeometry SetMainSection(
	GeometrySection newMainSection,
	ConnectiveGeometry geometry
)

Parameters

newMainSection
Type: Tekla.Structures.ModelGeometrySection
Geometry section to set as main section.
geometry
Type: Tekla.Structures.ModelConnectiveGeometry
Connective geometry to modify.

Return Value

Type: ConnectiveGeometry
Connective geometry with newMainSection as main section.
Exceptions
ExceptionCondition
ArgumentExceptionThrows an ArgumentException exception if the input newMainSection is not a polygon section.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next