RebarEndDetailModifier Class

The RebarEndDetailModifier class represents a modifier that can modify the characteristics of RebarSet reinforcing bars that pass through it. It can modify reinforcing bar end properties and will therefore affect the end of the reinforcing bars it is nearest to.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarEndDetailModifier : BaseRebarModifier

The RebarEndDetailModifier type exposes the following members.

Constructors
  NameDescription
Public methodRebarEndDetailModifier
Initializes a new instance of the RebarEndDetailModifier class.
Top
Properties
  NameDescription
Public propertyEndType
Gets or sets the end type.
Public propertyRebarCranking
Gets or sets the rebar cranking.
Public propertyRebarHook
Gets or sets the reinforcing bar hook data.
Public propertyRebarLengthAdjustment
Gets or sets the reinforcing bar length adjustment data.
Public propertyRebarThreading
Gets or sets the reinforcing bar threading data.
Top
Methods
  NameDescription
Public methodGetAffectedBars
Gets the virtual bars affected by this modifier.
Top
Examples
The following example shows how to create and add a RebarEndDetailModifier, to a rebarset.
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
            // Create and insert a rebarset (see the RebarSet example).
            var rebarSet = new RebarSet();

            // Create the RebarEndDetailModifier.
            var strip = new RebarEndDetailModifier();
            strip.Father = rebarSet;
            strip.EndType = RebarEndDetailModifier.EndTypeEnum.HOOK;
            strip.RebarHook.Shape = RebarHookData.RebarHookShapeEnum.HOOK_90_DEGREES;
            strip.RebarThreading.ThreadingType = "ThreadingType1";
            strip.RebarThreading.Length = 100;
            strip.RebarThreading.ExtraFabricationLength = 50;
            strip.Curve.AddContourPoint(new ContourPoint(new Point(0, 200, 500), null));
            strip.Curve.AddContourPoint(new ContourPoint(new Point(0,1000, 500), null));
            strip.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next