AnalysisResultResultPositionEnum Enumeration

The result position.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public enum ResultPositionEnum
Members
  Member nameValueDescription
POSITION_BY_COORDINATES0 The position given by the coordinates X, Y and Z.
POSITION_BY_COORDINATES_MINUS6 The position given by the coordinates X, Y and Z (minus side).
POSITION_BY_COORDINATES_PLUS7 The position given by the coordinates X, Y and Z (plus side).
POSITION_BEAM_START_POINT1 The member start position.
POSITION_BEAM_END_POINT2 The member end position.
POSITION_BEAM_MID_POINT3 The member middle position.
POSITION_BEAM_MID_POINT_MINUS4 The member middle position (minus side).
POSITION_BEAM_MID_POINT_PLUS5 The member middle position (plus side).
POSITION_MAX_NO_COORDINATES201 No position specified, gets the maximum.
POSITION_MIN_NO_COORDINATES203 No position specified, gets the minimum.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next