BentPlate Class

A class for the bent plate
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class BentPlate : Part

The BentPlate type exposes the following members.

Constructors
  NameDescription
Public methodBentPlate
Initializes a new instance of the BentPlate class.
Top
Properties
  NameDescription
Public propertyGeometry
Gets or sets the geometry of the bent plate.
Public propertyThickness
Gets thickness of the bent plate.
Top
Methods
  NameDescription
Public methodDelete
Deletes the bent plate with this instance identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the bent plate into the model database. All the attributes must be set and geometry should have at least one bend.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the bent plate object values in the database.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a bent plate object from the database.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Geometry3d;
using Tekla.Structures.Model;

public class Example
{
           private ContourPlate CreateContourPlate(Point point1, Point point2, Point point3)
           {
               ContourPoint contourPoint1 =  new ContourPoint(point1, null);
               ContourPoint contourPoint2 = new ContourPoint(point2, null);
               ContourPoint contourPoint3 = new ContourPoint(point3, null);

               ContourPlate CP = new ContourPlate();

               CP.AddContourPoint(contourPoint1);
               CP.AddContourPoint(contourPoint2);
               CP.AddContourPoint(contourPoint3);
               CP.Finish = "FOO";
               CP.Profile.ProfileString = "PL200";
               CP.Material.MaterialString = "Steel_Undefined";

               CP.Insert();

               return CP;
           }

           public void Example1()
           {
               Point point1 = new Point(0, 4000, 1000);
               Point point2 = new Point(2000, 4000, 1000);
               Point point3 = new Point(0, 6000, 3000);

               Point point4 = new Point(0, 0, 0);
               Point point5 = new Point(0, 2000, 0);
               Point point6 = new Point(2000, 2000, 0);

               Part contourPlate1 = CreateContourPlate(point1, point2, point3);
               Part contourPlate2 = CreateContourPlate(point4, point5, point6);
               BentPlate bentPlate = Operations.Operation.CreateBentPlateByParts(contourPlate1, contourPlate2);
           }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next