BentPlate Class

A class for the bent plate
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class BentPlate : Part

The BentPlate type exposes the following members.

Constructors
  NameDescription
Public methodBentPlate
Initializes a new instance of the BentPlate class.
Top
Properties
  NameDescription
Public propertyAssemblyNumber
Gets or sets the assembly number. Defines the numbering in the assembly sense.
(Inherited from Part.)
Public propertyCastUnitType
Gets or sets the cast unit type of the part.
(Inherited from Part.)
Public propertyClass
Gets or sets the class of the part.
(Inherited from Part.)
Public propertyDeformingData
Gets or sets the deforming data of the part.
(Inherited from Part.)
Public propertyFinish
Gets or sets the finish of the part.
(Inherited from Part.)
Public propertyGeometry
Gets or sets the geometry of the bent plate.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyMaterial
Gets or sets the material the part is made of.
(Inherited from Part.)
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
Gets or sets the name of the part.
(Inherited from Part.)
Public propertyPartNumber
Gets or sets the part number. Defines the numbering in the part sense.
(Inherited from Part.)
Public propertyPosition
Gets or sets the part position. Defines the way the part is positioned in the model.
(Inherited from Part.)
Public propertyPourPhase
Gets or sets the pour phase of the part.
(Inherited from Part.)
Public propertyProfile
Gets or sets the profile of the part.
(Inherited from Part.)
Public propertyThickness
Gets thickness of the bent plate.
Top
Methods
  NameDescription
Public methodCompareTo(Object)
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodCompareTo(Part)
Compares the instantiated part with another one.
(Inherited from Part.)
Public methodDelete
Deletes the bent plate with this instance identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAssembly
Returns the assembly that the part belongs to.
(Inherited from Part.)
Public methodGetBolts
Returns an enumerator of all the connected bolts.
(Inherited from Part.)
Public methodGetBooleans
Returns an enumerator of all the connected boolean objects.
(Inherited from Part.)
Public methodGetCenterLine
Returns the center line for the given part.
(Inherited from Part.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetComponents
Returns an enumerator of all the connected components, connections, seams and details inherited from the base component.
(Inherited from Part.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDSTVCoordinateSystem
Get DSTV coordinate system.
(Inherited from Part.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPartMark
Returns the part mark.
(Inherited from Part.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetPours
Returns an enumerator of all the pours that the part belongs to.
(Inherited from Part.)
Public methodGetReferenceLine
Returns the reference line for the given part.
(Inherited from Part.)
Public methodGetReinforcements
Returns an enumerator of all the connected reinforcements.
(Inherited from Part.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSolid
Returns the solid of the part.
(Inherited from Part.)
Public methodGetSolid(FormingStates)
Returns the solid of the part.
(Inherited from Part.)
Public methodGetSolid(SolidSolidCreationTypeEnum)
Returns the solid of the part.
(Inherited from Part.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetSurfaceObjects
Returns an enumerator of all the connected surface objects.
(Inherited from Part.)
Public methodGetSurfaceTreatments
Returns an enumerator of all the connected surface treatments.
(Inherited from Part.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodGetWelds
Returns an enumerator of all the connected welds.
(Inherited from Part.)
Public methodInsert
Inserts the bent plate into the model database. All the attributes must be set and geometry should have at least one bend.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the bent plate object values in the database.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a bent plate object from the database.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Geometry3d;
using Tekla.Structures.Model;

public class Example
{
           private ContourPlate CreateContourPlate(Point point1, Point point2, Point point3)
           {
               ContourPoint contourPoint1 =  new ContourPoint(point1, null);
               ContourPoint contourPoint2 = new ContourPoint(point2, null);
               ContourPoint contourPoint3 = new ContourPoint(point3, null);

               ContourPlate CP = new ContourPlate();

               CP.AddContourPoint(contourPoint1);
               CP.AddContourPoint(contourPoint2);
               CP.AddContourPoint(contourPoint3);
               CP.Finish = "FOO";
               CP.Profile.ProfileString = "PL200";
               CP.Material.MaterialString = "Steel_Undefined";

               CP.Insert();

               return CP;
           }

           public void Example1()
           {
               Point point1 = new Point(0, 4000, 1000);
               Point point2 = new Point(2000, 4000, 1000);
               Point point3 = new Point(0, 6000, 3000);

               Point point4 = new Point(0, 0, 0);
               Point point5 = new Point(0, 2000, 0);
               Point point6 = new Point(2000, 2000, 0);

               Part contourPlate1 = CreateContourPlate(point1, point2, point3);
               Part contourPlate2 = CreateContourPlate(point4, point5, point6);
               BentPlate bentPlate = Operations.Operation.CreateBentPlateByParts(contourPlate1, contourPlate2);
           }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next