StringList Class

The StringList class defines a type safe string collection.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class StringList : CollectionBase

The StringList type exposes the following members.

Constructors
  NameDescription
Public methodStringList
Creates a new string list instance.
Public methodStringList(Int32)
Creates a new string list instance with the given capacity.
Top
Properties
  NameDescription
Public propertyItem
Gets or sets the string at the specified index.
Top
Methods
  NameDescription
Public methodAdd
Adds a new string to the end of the string list.
Public methodContains
Checks if the string is in the list.
Public methodGetRange
Gets a part of the string list.
Public methodIndexOf(String)
Gets the index of the specified string.
Public methodIndexOf(String, Int32)
Gets the index of the specified string between the index to start the search from and the end of the list.
Public methodIndexOf(String, Int32, Int32)
Gets the index of the specified string between the index to start the search from and startIndex + count.
Public methodInsert
Inserts the string to the specified index.
Public methodIsEqual
Compares the current object with an object of the same type.
Public methodLastIndexOf(String)
Searches for the last occurence of the string in the list.
Public methodLastIndexOf(String, Int32)
Searches for the last occurence of the string in the list.
Public methodLastIndexOf(String, Int32, Int32)
Searches for the last occurence of the string in the list.
Public methodRemove
Removes the first occurence of the string from the list.
Public methodRemoveRange
Removes a range of items starting from the given index.
Public methodToArray
Copies the strings to a string array.
Top
Examples
using Tekla.Structures.Drawing;

public class Example
{
       public void Example1()
       {
           StringList stringList = new StringList();

           stringList.Add("MyString");
           stringList.Add("MySecondString");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next