ReinforcementBaseReinforcementSetGroupAttributes Class

The ReinforcementSetGroupAttributes class is the base attributes class for ReinforcementSetGroup.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ReinforcementSetGroupAttributes : ReinforcementBaseReinforcementBaseAttributes

The ReinforcementBaseReinforcementSetGroupAttributes type exposes the following members.

Constructors
  NameDescription
Public methodReinforcementBaseReinforcementSetGroupAttributes
Initializes a new instance of the ReinforcementBaseReinforcementSetGroupAttributes class.
Public methodReinforcementBaseReinforcementSetGroupAttributes(String)
Initializes a new instance of the ReinforcementBaseReinforcementSetGroupAttributes class that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyCustomPresentation
Custom presentation GUID to be applied to the object type
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyHiddenLines
The line type of the hidden lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyHideLinesHiddenByPart
Defines whether lines hidden by parts should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyHideLinesHiddenByReinforcement
Defines whether lines hidden by reinforcements should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyHookedEndSymbolType
Gets or sets how the hooked ends of reinforcing bars should look like.
Public propertyReinforcementRepresentation
The representation of reinforcing bars.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyReinforcementVisibility
Gets or sets which bars in the group appear in drawings.
Public propertyStraightEndSymbolType
Gets or sets how the straight ends of reinforcing bars should look like.
Public propertyVisibleLines
The line type of the visible lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next