Task Constructor (Identifier)

Creates a task instance with a known identifier. Select the task after the creation.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public Task(
	Identifier ID
)

Parameters

ID
Type: Tekla.StructuresIdentifier
The identifier of an existing task.
Examples
using Tekla.Structures.Model;
using Tekla.Structures;

public class Example
{
       public void Example1()
       {
           Identifier Identifier1 = new Identifier(357);

           bool Result = true;
           Task Task1 = new Task(Identifier1);
           Task1.Select();
           ModelObjectEnumerator TaskChildren = Task1.GetChildren();
           foreach (Task ChildTask in TaskChildren)
           {
               ChildTask.Name += " (modified)";
               Result = ChildTask.Modify();
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next