ModuleManagerProgramConfigurationEnum Enumeration

The configuration information of the program.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public enum ProgramConfigurationEnum
Members
  Member nameValueDescription
CONFIGURATION_VIEWER0 The viewer configuration.
CONFIGURATION_PRODUCTION_PLANNER1 The production planner configuration.
CONFIGURATION_DRAFTER2 The drafter configuration.
CONFIGURATION_PROJECT_MANAGEMENT3 The project management configuration.
CONFIGURATION_ENGINEERING4 The construction management configuration.
CONFIGURATION_REINFORCED_CONCRETE_DETAILING5 The reinforced concrete detailing configuration.
CONFIGURATION_PRECAST_CONCRETE_DETAILING6 The precast concrete detailing configuration.
CONFIGURATION_STEEL_DETAILING7 The steel detailing configuration.
CONFIGURATION_FULL8 The full detailing configuration.
CONFIGURATION_PRIMARY9 The Primary configuration.
CONFIGURATION_EDUCATIONAL10 The educational configuration.
CONFIGURATION_DEVELOPER11 The developer configuration.
CONFIGURATION_CONSTRUCTION_MODELING12 The construction management configuration with modeling capabilities.
CONFIGURATION_STEEL_DETAILING_LIMITED9 The old steel detailing limited configuration. This definition was left here to enable old macros in 19.0.
CONFIGURATION_CONSTRUCTION_VIEWER12 The construction management configuration restricted to viewer mode.
CONFIGURATION_CONSTRUCTION_MANAGEMENT12
CONFIGURATION_PARTNER13 The partner configuration.
CONFIGURATION_EPM_MODELER14 The EPM Modeler configuration.
CONFIGURATION_CARBON15 The Carbon configuration.
CONFIGURATION_GRAPHITE16 The Graphite configuration.
CONFIGURATION_DIAMOND17 The Diamond configuration.
CONFIGURATION_MEP18 The MEP configuration.
CONFIGURATION_TRIAL19 The Trial Configuration.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next