ReferenceModel Class

The ReferenceModel class contains methods related to reference models. A reference model is a reference of an external model.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ReferenceModel : ModelObject

The ReferenceModel type exposes the following members.

Constructors
  NameDescription
Public methodReferenceModel
Initializes a new instance of the ReferenceModel class.

The default values are as follows:

  • Filename = string.Empty;
  • ActiveFilePath = string.Empty;
  • ProjectGUID = Guid.Empty;
  • ModelGUID = Guid.Empty;
  • VersionGUID = Guid.Empty;
  • Position = new Point();
  • Scale = 1.0;
  • Visibility = VisibilityEnum.VISIBLE;
  • BasePointGuid = string.Empty;
Public methodReferenceModel(String, Point, Double)
Initializes a new instance of the ReferenceModel class. Creates a new reference model instance using the given filename, position and scale.
Top
Properties
  NameDescription
Public propertyActiveFilePath
Gets the path to the local copy of the current revision of the reference model.
Public propertyBasePointGuid
The GUID of the used base point. Empty if base point is not used.
Public propertyFilename
The path to the original location of the reference file.
Public propertyModelGUID Obsolete.
The ModelGUID of the reference model in the Project Center.
Public propertyPosition
The position of the reference model.
Public propertyProjectGUID Obsolete.
The ProjectGUID of the reference model in the Project Center.
Public propertyRotation Obsolete.
Gets or sets value of rotation around Z axis (degrees).
Public propertyRotation3D
Gets or sets value of 3d rotation.
Public propertyScale
The scale of the reference model.
Public propertyTitle
The reference model name(title).
Public propertyUseWorkplane
Sets whether workplane is used.
Public propertyVersionGUID Obsolete.
The VersionGUID of the reference model in the Project Center.
Public propertyVisibility
The visibility of the reference model in the model view.
Top
Methods
  NameDescription
Public methodDelete
Deletes the reference model with the given identifier.
(Overrides ModelObjectDelete.)
Public methodGetChildren
Returns an enumerator of all the children reference model objects.
(Overrides ModelObjectGetChildren.)
Public methodGetConvertedObjects
Returns an enumerator of model object converted from the reference model.
Public methodGetCurrentRevision
Gets the current revision.
Public methodGetReferenceModelObjectByExternalGuid
Gets reference model object by external (IFC) guid from this reference model.
Public methodGetReferenceModelObjectGuidsByExternalGuids
Gets reference model object guids by external guids.
Public methodGetRevisions
Gets the reference models available revisions.
Public methodInsert
Inserts the reference model into the model.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the reference model with the given identifier.
(Overrides ModelObjectModify.)
Public methodRefreshFile
Reload the reference file from the location specified by Filename. If the file has changed, a new revision will be created and taken into use. Note that if a new revision was successfully created, the ActiveFilePath is changed.
Public methodRemoveRevision
Removes the given revision from the reference model.
Public methodSelect
Selects the reference model with the given identifier.
(Overrides ModelObjectSelect.)
Public methodSetAsCurrentRevision(ReferenceModelRevision)
Sets the given revision as current revision.
Public methodSetAsCurrentRevision(Int32, Int32)
Sets the given revision as current revision.
Top
Examples
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           ReferenceModel ReferenceModel = new ReferenceModel();
           ReferenceModel.Filename = "c:\\TeklaStructuresModels\\reference_model.dwg";
           ReferenceModel.Scale = 1.0;

           bool Result = false;
           Result = ReferenceModel.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next