ReferenceModel Class

The ReferenceModel class contains methods related to reference models. A reference model is a reference of an external model.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ReferenceModel : ModelObject

The ReferenceModel type exposes the following members.

Constructors
  NameDescription
Public methodReferenceModel
Initializes a new instance of the ReferenceModel class.

The default values are as follows:

  • Filename = string.Empty;
  • ActiveFilePath = string.Empty;
  • ProjectGUID = Guid.Empty;
  • ModelGUID = Guid.Empty;
  • VersionGUID = Guid.Empty;
  • Position = new Point();
  • Scale = 1.0;
  • Visibility = VisibilityEnum.VISIBLE;
  • BasePointGuid = string.Empty;
Public methodReferenceModel(String, Point, Double)
Initializes a new instance of the ReferenceModel class. Creates a new reference model instance using the given filename, position and scale.
Top
Properties
  NameDescription
Public propertyActiveFilePath
Gets the path to the local copy of the current revision of the reference model.
Public propertyBasePointGuid
The GUID of the used base point. Empty if base point is not used.
Public propertyFilename
The path to the original location of the reference file.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyModelGUID Obsolete.
The ModelGUID of the reference model in the Project Center.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyPosition
The position of the reference model.
Public propertyProjectGUID Obsolete.
The ProjectGUID of the reference model in the Project Center.
Public propertyRotation Obsolete.
Gets or sets value of rotation around Z axis (degrees).
Public propertyRotation3D
Gets or sets value of 3d rotation.
Public propertyScale
The scale of the reference model.
Public propertyTitle
The reference model name(title).
Public propertyUseWorkplane
Sets whether workplane is used.
Public propertyVersionGUID Obsolete.
The VersionGUID of the reference model in the Project Center.
Public propertyVisibility
The visibility of the reference model in the model view.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the reference model with the given identifier.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children reference model objects.
(Overrides ModelObjectGetChildren.)
Public methodGetConvertedObjects
Returns an enumerator of model object converted from the reference model.
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetCurrentRevision
Gets the current revision.
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReferenceModelObjectByExternalGuid
Gets reference model object by external (IFC) guid from this reference model.
Public methodGetReferenceModelObjectGuidsByExternalGuids
Gets reference model object guids by external guids.
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetRevisions
Gets the reference models available revisions.
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the reference model into the model.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the reference model with the given identifier.
(Overrides ModelObjectModify.)
Public methodRefreshFile
Reload the reference file from the location specified by Filename. If the file has changed, a new revision will be created and taken into use. Note that if a new revision was successfully created, the ActiveFilePath is changed.
Public methodRemoveRevision
Removes the given revision from the reference model.
Public methodSelect
Selects the reference model with the given identifier.
(Overrides ModelObjectSelect.)
Public methodSetAsCurrentRevision(ReferenceModelRevision)
Sets the given revision as current revision.
Public methodSetAsCurrentRevision(Int32, Int32)
Sets the given revision as current revision.
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           ReferenceModel ReferenceModel = new ReferenceModel();
           ReferenceModel.Filename = "c:\\TeklaStructuresModels\\reference_model.dwg";
           ReferenceModel.Scale = 1.0;

           bool Result = false;
           Result = ReferenceModel.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next