CutPlane Class

The CutPlane class defines how the end of a part is cut with a plane. A cut plane differs from a fitting because a cut can never extend the boundaries of the original part.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class CutPlane : Boolean

The CutPlane type exposes the following members.

Constructors
  NameDescription
Public methodCutPlane
Initializes a new instance of the CutPlane class with empty attributes.
Top
Properties
  NameDescription
Public propertyPlane
The plane that cuts the part.
Top
Methods
  NameDescription
Public methodDelete
Deletes the cut plane instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the cut plane into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing cut plane in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a cut plane from the model database. The part ID must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point Point = new Point(0, 0, 0);
           Point Point2 = new Point(1000, 0, 0);

           Beam Beam = new Beam();
           Beam.StartPoint = Point;
           Beam.EndPoint = Point2;
           Beam.Profile.ProfileString = "HEA400";
           Beam.Finish = "PAINT";
           Beam.Insert();

           CutPlane CutPlane = new CutPlane();
           CutPlane.Plane = new Plane();
           CutPlane.Plane.Origin = new Point(0, 0, 0);
           CutPlane.Plane.AxisX = new Vector(0, 1000, 0);
           CutPlane.Plane.AxisY = new Vector(0, 0, -1000);
           CutPlane.Father = Beam;
           CutPlane.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next