AngleDimensionAttributes Class

The AngleDimensionAttributes class contains the attributes for angle dimensions.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class AngleDimensionAttributes : DimensionSetBaseAttributes

The AngleDimensionAttributes type exposes the following members.

Constructors
  NameDescription
Public methodAngleDimensionAttributes
Creates a new angle dimension attributes instance which loads standard attributes.
Public methodAngleDimensionAttributes(String)
Creates a new angle dimension attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyArrowhead
The arrowhead attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.)
Public propertyColor
The color of the dimension line.
(Inherited from DimensionSetBaseAttributes.)
Public propertyFormat
The format attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.)
Public propertyPlacing
The placing attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.)
Public propertyText
The text attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.)
Public propertyTransparentBackground
The dimension text background transparency. (transparent/opaque)
(Inherited from DimensionSetBaseAttributes.)
Public propertyTriangleBase
Gets or sets the triangle base length which controls the base dimension shown for bevel dimensions (only if Type is AngleTypes.Triangle).
Public propertyType
The type of the angle.
Top
Methods
Examples
using Tekla.Structures.Drawing;

public class Example
{
       public void Example1()
       {
           AngleDimensionAttributes attributes = new AngleDimensionAttributes("MyAttributes");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next