ReinforcementMesh Class

The ReinforcementMesh class defines a reinforcement mesh in the drawing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class ReinforcementMesh : ReinforcementBase

The ReinforcementMesh type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
(Inherited from ModelObject.)
Public propertyModelIdentifier
The database identifier of the model object in the model database. By using this identifier, it is possible to select the actual object in the Tekla Structures model.
(Inherited from ModelObject.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertyReinforcementCustomPositionCrossing
Defines the location of the crossing bar when using MeshReinforcementVisibilityCrossing == ReinforcementVisibilityTypes.Customized. This location is a value between 0.0 and 1.0 and it defines the proportion from the mesh's start point.
Public propertyReinforcementCustomPositionLongitudinal
Defines the location of the longitudinal wire when using ReinforcementVisibility == ReinforcementVisibilityTypes.Customized. This location is a value between 0.0 and 1.0 and it defines the proportion from the reinforcement's start point.
Top
Methods
  NameDescription
Public methodDelete
Deletes the drawing reinforcement from the current drawing database.
(Inherited from ReinforcementBase.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Inserts the drawing reinforcement into the current drawing database. NOT YET IMPLEMENTED.
(Inherited from ReinforcementBase.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the drawing reinforcement in the current drawing database.
(Inherited from ReinforcementBase.)
Public methodSelect
Selects the drawing reinforcement from the current drawing database.
(Inherited from ReinforcementBase.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next