ReinforcementMesh Class

The ReinforcementMesh class defines a reinforcement mesh in the drawing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class ReinforcementMesh : ReinforcementBase

The ReinforcementMesh type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Public propertyReinforcementCustomPositionCrossing
Defines the location of the crossing bar when using MeshReinforcementVisibilityCrossing == ReinforcementVisibilityTypes.Customized. This location is a value between 0.0 and 1.0 and it defines the proportion from the mesh's start point.
Public propertyReinforcementCustomPositionLongitudinal
Defines the location of the longitudinal wire when using ReinforcementVisibility == ReinforcementVisibilityTypes.Customized. This location is a value between 0.0 and 1.0 and it defines the proportion from the reinforcement's start point.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next