AnalysisResult Class

The AnalysisResult class contains analysis result information.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisResult

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisResult

The AnalysisResult type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisResult
Creates a new analysis result instance.
Top
Properties
  NameDescription
Public propertyLoadCase
The load case. The real load cases have positive values 1, 2, 3, ... For min/max queries LoadCaseForMinMaxEnum can be used.
Public propertyLoadCaseInfo
The load case info (optional, max length 128).
Public propertyLoadCaseName
The load case name (max length 64).
Public propertyLoadCaseType
The load case type.
Public propertyModId
The time stamp of the result.
Public propertyObjectId
The identifier of the object. If ObjectType is OBJECT_TYPE_PART, ObjectId is (physical) part ID. If ObjectType is OBJECT_TYPE_MEMBER, ObjectId is the bar number when analysis bars are used in integration, otherwise ObjectId is the member number. If ObjectType is OBJECT_TYPE_AREA, ObjectId is the area number.
Public propertyObjectType
The object type. In result query the only supported type is the physical member (the part).
Public propertyPosition
The position on the part's START/END/...
Public propertyPositionCoordX
Global coordinate X (mm) when inserting result. Local (part) coordinate X (mm) when getting results.
Public propertyPositionCoordY
Global coordinate Y (mm) when inserting result. Local (part) coordinate Y (mm) when getting results.
Public propertyPositionCoordZ
Global coordinate Z (mm) when inserting result. Local (part) coordinate Z (mm) when getting results.
Public propertyPositionTolerance
The position's coordinate tolerance.
Public propertyValue
The result value.
Public propertyValueType
The result value type.
Top
Methods
  NameDescription
Public methodStatic memberCode exampleDelete
Delete analysis results by the given key.
Public methodStatic memberCode exampleDeleteAll
Delete all analysis results.
Public methodStatic memberCode exampleDeleteLoadcase
Delete analysis results by load case.
Public methodStatic memberGetResultObjectIds
Get ID numbers of objects with results.
Public methodStatic memberGetResults
Get analysis results.
Public methodCode exampleInsert
Insert analysis result. Results are always stored to physical parts. When OBJECT_TYPE_MEMBER or OBJECT_TYPE_AREA is used the analysis model must be active. All results for given part must be inserted within one commit (CommitChanges), older results of this part are removed automatically.
Public methodQueryAnalysisResult
Queries an analysis result.
Top
Examples
The following example queries a single analysis result value.
using Tekla.Structures.Analysis;

public class Example
{
       public void Example1()
       {
           int PartId = 0;

           AnalysisResult AnalysisResult = new AnalysisResult();

           AnalysisResult.ObjectType = AnalysisResult.ObjectTypeEnum.OBJECT_TYPE_PART;
           AnalysisResult.ObjectId = PartId;
           AnalysisResult.LoadCase = (int)AnalysisResult.LoadCaseForMinMaxEnum.LOADCASE_WITH_MAX_ABSOLUTE_VALUE;
           AnalysisResult.Position = AnalysisResult.ResultPositionEnum.POSITION_BEAM_START_POINT;
           AnalysisResult.PositionCoordX = 0.0;
           AnalysisResult.PositionCoordY = 0.0;
           AnalysisResult.PositionCoordZ = 0.0;
           AnalysisResult.PositionTolerance = 0.1;
           AnalysisResult.ValueType = AnalysisResult.ValueTypeEnum.VALUETYPE_SHEAR_Y;

           bool Result = AnalysisResult.QueryAnalysisResult();

           double ResultValue = AnalysisResult.Value;
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next