AnalysisDecomposedAreaLoad Class

The AnalysisDecomposedAreaLoad class contains decomposed area load information.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisDecomposedAreaLoad : AnalysisDecomposedLoad

The AnalysisDecomposedAreaLoad type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisDecomposedAreaLoad
Initializes a new instance of the AnalysisDecomposedAreaLoad class
Top
Properties
  NameDescription
Public propertyAnalysisLoadType
Gets or sets the type of the analysis decomposed load.
(Inherited from AnalysisDecomposedLoad.)
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyDirection
The direction of the decomposed area load.
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyMagnitudes
The magnitudes of the decomposed area load.
Public propertyModelLoadGroupID
Gets or sets the identifier of the load group.
(Inherited from AnalysisDecomposedLoad.)
Public propertyModelLoadID
Gets or sets the identifier of the model load.
(Inherited from AnalysisDecomposedLoad.)
Public propertyObjectAttachedToID
Gets or sets the identifier of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.)
Public propertyObjectAttachedToType
Gets or sets the type of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.)
Public propertyPositions
The positions of the decomposed area load.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next