PluginBaseInputObjectDependency Enumeration

Defines the input object dependency type for model plug-ins.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public enum InputObjectDependency
Members
  Member nameValueDescription
NOT_DEPENDENT0 No dependency on input. Typically this type is applied to the import and export functionality. Not-dependent plug-ins are executed from the plug-in dialog instead of the component catalog. The created objects do not have any relation to the plug-in anymore. The plug-in dialog cannot be opened from the created objects. Note! The system does not automatically save a rollback point to the database for non-dependent plug-ins. If new objects are created, CommitChanges needs to be called at the end of the Run method.
DEPENDENT1 Dependent on input. The plug-in is executed if e.g. the definition points or the profile of the input part change. Boolean operations to the input part do not cause plug-in execution.
GEOMETRICALLY_DEPENDENT2 Geometrically dependent on input. The plug-in is executed if the input part geometry changes i.e. if the input part is fitted.
NOT_DEPENDENT_MODIFIABLE3 No dependency on input but the instance is modifiable in the model. The created objects have a relation to the plug-in. The plug-in dialog can be opened from the created objects.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next