AnalysisAreaPolygon Class

The AnalysisAreaPolygon class contains information related to analysis area polygons.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public class AnalysisAreaPolygon : AnalysisObject

The AnalysisAreaPolygon type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisAreaPolygon
Creates a new instance of the AnalysisAreaPolygon class.
Top
Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyEdges
The edges of the area polygon.
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyPositions
The positions of the area polygon.
Top
Methods
  NameDescription
Public methodAdd
Adds a position to the analysis area polygon. Also adds an edge.
Public methodGetEdges
Gets the edges of the area polygon.
Public methodGetPositions
Gets the positions of the area polygon.
Public methodInsert
Inserts an analysis area polygon. The AnalysisModelName has to be set.
Public methodSelect
Selects an analysis area polygon. The AnalysisObjectType has to be set.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next