MateriaClientAdapter Class

Adapter class used for Materia-TS integration.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.TeklaStructuresInternal.MateriaClientMateriaClientAdapter

Namespace:  Tekla.Structures.TeklaStructuresInternal.MateriaClient
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public class MateriaClientAdapter : IMateriaClientAdapter, 
	IDisposable

The MateriaClientAdapter type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberInstance
Get the IMateriaClientAdapter instance
Top
Methods
  NameDescription
Public methodConnect
Tries to connect to the Materia server. Note: this method must be called from the UI thread
Public methodDisconnect
Disconnect from Materia server
Public methodDispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public methodIsConnectionActive
Returns the value whether connection to Materia server is active or not.
Public methodLoadGraph(Asset)
Loads the graph corresponding to the specified uri and retrieves it's GUID
Public methodLoadGraph(Asset, ListGraphParameter)
Loads the graph corresponding to the specified uri providing the explicit parameter values and retrieves it's GUID
Public methodSearchAssets
Searches for materia assets by name and retrieves a list of asset names and guids.
Top
Events
  NameDescription
Public eventConnectionChanged
Event for notifying about connection changes
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next