CurvedRebarGroup Class

The CurvedRebarGroup class represents a group of reinforcing bars which have a curved shape.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class CurvedRebarGroup : BaseRebarGroup

The CurvedRebarGroup type exposes the following members.

Constructors
  NameDescription
Public methodCurvedRebarGroup
Initializes a new curved rebar group instance with empty attributes.
Top
Properties
  NameDescription
Public propertyClass
Gets or sets the class of the reinforcement. The class is used to group reinforcements.
(Inherited from Reinforcement.)
Public propertyEndFromPlaneOffset
The end offset value from the part surface.
(Inherited from BaseRebarGroup.)
Public propertyEndHook
The hook at the end of the reinforcing bar.
(Inherited from BaseRebarGroup.)
Public propertyEndPoint
The end point of the direction in which the bars are distributed.
(Inherited from BaseRebarGroup.)
Public propertyEndPointOffsetType
Gets or sets the type of the end point offset. The options are:
  • OFFSET_TYPE_LEG_LENGTH
  • OFFSET_TYPE_COVER_THICKNESS
(Inherited from Reinforcement.)
Public propertyEndPointOffsetValue
Gets or sets the concrete cover thickness or leg length at the second end of the bar.
(Inherited from Reinforcement.)
Public propertyExcludeType
Defines which bars to omit from the group. The options are:
  • EXCLUDE_TYPE_NONE
  • EXCLUDE_TYPE_FIRST
  • EXCLUDE_TYPE_LAST
  • EXCLUDE_TYPE_BOTH
(Inherited from BaseRebarGroup.)
Public propertyFather
Gets or sets the father object of the reinforcement; the model object instance to operate on.
(Inherited from Reinforcement.)
Public propertyFromPlaneOffset
The offset value from the part surface applied in both sides.
(Inherited from BaseRebarGroup.)
Public propertyGrade
Gets or sets the steel grade of the reinforcing bar. The grade indicates the strength of the steel used in reinforcing bars. It can also indicate other factors, such as the weldability or surface deformations of the bar.
(Inherited from Reinforcement.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyInputPointDeformingState
Gets or sets the reinforcement input point deforming state.
(Inherited from Reinforcement.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
Gets or sets the name of the reinforcement.
(Inherited from Reinforcement.)
Public propertyNumberingSeries
Gets or sets the numbering series of the reinforcement.
(Inherited from Reinforcement.)
Public propertyOnPlaneOffsets
Gets or sets the double offset value for each leg on the same plane as the bar.
(Inherited from Reinforcement.)
Public propertyPolygon
A polygon definition for the curved reinforcing bar group shape. The polygon must have 3 points.
Public propertyRadiusValues
Gets or sets the radius value(s) of the bends in the bar.
(Inherited from Reinforcement.)
Public propertySize
The size of the reinforcement.
(Inherited from BaseRebarGroup.)
Public propertySpacings
The spacing value(s). If the type of the spacing is SPACING_TYPE_EXACT_NUMBER Spacings has only one value that defines the number of the reinforcing bars.
(Inherited from BaseRebarGroup.)
Public propertySpacingType
The type of spacing. The options are (BaseRebarGroup.RebarGroupSpacingTypeEnum.):
  • SPACING_TYPE_UNDEFINED
  • SPACING_TYPE_EXACT_SPACINGS
  • SPACING_TYPE_EXACT_NUMBER
  • SPACING_TYPE_TARGET_SPACE
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_START
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_END
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_BOTH
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_MIDDLE
(Inherited from BaseRebarGroup.)
Public propertyStartFromPlaneOffset
The start offset value from the part surface.
(Inherited from BaseRebarGroup.)
Public propertyStartHook
The hook at the beginning of the reinforcing bar.
(Inherited from BaseRebarGroup.)
Public propertyStartPoint
The start point of the direction in which the bars are distributed.
(Inherited from BaseRebarGroup.)
Public propertyStartPointOffsetType
Gets or sets the type of the start point offset is either OFFSET_TYPE_LEG_LENGTH or OFFSET_TYPE_COVER_THICKNESS.
(Inherited from Reinforcement.)
Public propertyStartPointOffsetValue
Gets or sets the concrete cover thickness or leg length at the first end of the bar.
(Inherited from Reinforcement.)
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the curved rebar group instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAssembly
Returns the assembly that the reinforcement belongs to.
(Inherited from Reinforcement.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetFatherPour
Returns the pour that the rebar is associated to.
(Inherited from Reinforcement.)
Public methodGetFatherPourUnit
Returns the pour unit that the rebar is associated to.
(Inherited from Reinforcement.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetNumberOfRebars
Returns the number of rebars in the reinforcing group.
(Inherited from Reinforcement.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetRebarComplexGeometries(Boolean, Boolean, Boolean)
Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. RebarComplexGeometry only differs from RebarGeometry by containing a polycurve rather than a polyline.
(Inherited from Reinforcement.)
Public methodGetRebarComplexGeometries(Boolean, Boolean, Boolean, ReinforcementRebarGeometrySimplificationTypeEnum)
Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. RebarComplexGeometry only differs from RebarGeometry by containing a polycurve (of Arc and LineSegment objects) rather than a polyline. The polycurve only contains arcs if the "simplified" parameter is RATIONALIZED or FABRICATION. If "simplified" is NONE, any arcs will be returned as a series of line segments.
(Inherited from Reinforcement.)
Public methodGetRebarGeometries(Boolean)
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar.
(Inherited from Reinforcement.)
Public methodGetRebarGeometries(ReinforcementRebarGeometryOptionEnum)
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar.
(Inherited from Reinforcement.)
Public methodGetRebarGeometriesWithoutClashes
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar as shown in model view. In case rebar polygon clashes with itself, physical points are moved to avoid clashing.
(Inherited from Reinforcement.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSingleRebar
Returns a single rebar inside the rebar group located by the given index. The indexing starts from the start point. The rebar represents a physical reinforcing bar and contains physical points in the 3D space of the bar. The method returns null on error, for example if given an erroneous index. The number of rebars in the group can be requested with GetNumberOfRebars().
(Inherited from Reinforcement.)
Public methodGetSingleRebarWithoutClash
Returns a single rebar inside the rebar group located by the given index. The indexing starts from the start point. The rebar represents a physical reinforcing bar and contains physical, non-clashing points in the 3D space of the bar. The method returns null on error, for example if given an erroneous index. The number of rebars in the group can be requested with GetNumberOfRebars().
(Inherited from Reinforcement.)
Public methodGetSolid
Method for getting the solid information of the reinforcement.
(Inherited from Reinforcement.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the curved rebar group into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodIsGeometryValid
Tells whether the geometry of a reinforcement object is valid or not.
(Inherited from Reinforcement.)
Public methodModify
Modifies the existing curved rebar group in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a curved rebar group from the model database. The identifier of the curved rebar group must be set.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Beam Beam = new Beam(new Point(5000, 8000, 0), new Point(6000, 8000, 0));
           Beam.Profile.ProfileString = "D500";
           Beam.Material.MaterialString = "K40-1";
           Beam.Finish = "PAINT";
           Beam.Insert();

           double MinimumX = Beam.GetSolid().MinimumPoint.X;
           double MinimumY = Beam.GetSolid().MinimumPoint.Y;
           double MinimumZ = Beam.GetSolid().MinimumPoint.Z;
           double MaximumX = Beam.GetSolid().MaximumPoint.X;
           double MaximumY = Beam.GetSolid().MaximumPoint.Y;
           double MaximumZ = Beam.GetSolid().MaximumPoint.Z;

           CurvedRebarGroup CurvedRebarGroup = new CurvedRebarGroup();
           CurvedRebarGroup.Polygon.Points.Add(new Point(MinimumX, MaximumY, MinimumZ));
           CurvedRebarGroup.Polygon.Points.Add(new Point(MinimumX, MinimumY, MinimumZ));
           CurvedRebarGroup.Polygon.Points.Add(new Point(MinimumX, MinimumY, MaximumZ));
           CurvedRebarGroup.StartPoint = new Point(MinimumX, MaximumY, MinimumZ);
           CurvedRebarGroup.EndPoint = new Point(MaximumX, MaximumY, MinimumZ);
           CurvedRebarGroup.Father = Beam;
           CurvedRebarGroup.RadiusValues.Add(40.0);
           CurvedRebarGroup.SpacingType = BaseRebarGroup.RebarGroupSpacingTypeEnum.SPACING_TYPE_EXACT_SPACINGS;
           CurvedRebarGroup.Spacings.Add(30); //if you use: RebarGroup.Spacings.Add(30.0); ->then it works
           CurvedRebarGroup.ExcludeType = BaseRebarGroup.ExcludeTypeEnum.EXCLUDE_TYPE_NONE;
           CurvedRebarGroup.Name = "RebarGroup";
           CurvedRebarGroup.Class = 3;
           CurvedRebarGroup.Size = "8";
           CurvedRebarGroup.NumberingSeries.StartNumber = 0;
           CurvedRebarGroup.NumberingSeries.Prefix = "Group";
           CurvedRebarGroup.Grade = "A500HW";
           CurvedRebarGroup.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next