CurvedRebarGroup Class

The CurvedRebarGroup class represents a group of reinforcing bars which have a curved shape.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class CurvedRebarGroup : BaseRebarGroup

The CurvedRebarGroup type exposes the following members.

Constructors
  NameDescription
Public methodCurvedRebarGroup
Initializes a new curved rebar group instance with empty attributes.
Top
Properties
  NameDescription
Public propertyPolygon
A polygon definition for the curved reinforcing bar group shape. The polygon must have 3 points.
Public propertySpacingType
The type of spacing. The options are (BaseRebarGroup.RebarGroupSpacingTypeEnum.):
  • SPACING_TYPE_UNDEFINED
  • SPACING_TYPE_EXACT_SPACINGS
  • SPACING_TYPE_EXACT_NUMBER
  • SPACING_TYPE_TARGET_SPACE
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_START
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_END
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_BOTH
Top
Methods
  NameDescription
Public methodDelete
Deletes the curved rebar group instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the curved rebar group into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing curved rebar group in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a curved rebar group from the model database. The identifier of the curved rebar group must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Beam Beam = new Beam(new Point(5000, 8000, 0), new Point(6000, 8000, 0));
           Beam.Profile.ProfileString = "D500";
           Beam.Material.MaterialString = "K40-1";
           Beam.Finish = "PAINT";
           Beam.Insert();

           double MinimumX = Beam.GetSolid().MinimumPoint.X;
           double MinimumY = Beam.GetSolid().MinimumPoint.Y;
           double MinimumZ = Beam.GetSolid().MinimumPoint.Z;
           double MaximumX = Beam.GetSolid().MaximumPoint.X;
           double MaximumY = Beam.GetSolid().MaximumPoint.Y;
           double MaximumZ = Beam.GetSolid().MaximumPoint.Z;

           CurvedRebarGroup CurvedRebarGroup = new CurvedRebarGroup();
           CurvedRebarGroup.Polygon.Points.Add(new Point(MinimumX, MaximumY, MinimumZ));
           CurvedRebarGroup.Polygon.Points.Add(new Point(MinimumX, MinimumY, MinimumZ));
           CurvedRebarGroup.Polygon.Points.Add(new Point(MinimumX, MinimumY, MaximumZ));
           CurvedRebarGroup.StartPoint = new Point(MinimumX, MaximumY, MinimumZ);
           CurvedRebarGroup.EndPoint = new Point(MaximumX, MaximumY, MinimumZ);
           CurvedRebarGroup.Father = Beam;
           CurvedRebarGroup.RadiusValues.Add(40.0);
           CurvedRebarGroup.SpacingType = BaseRebarGroup.RebarGroupSpacingTypeEnum.SPACING_TYPE_EXACT_SPACINGS;
           CurvedRebarGroup.Spacings.Add(30); //if you use: RebarGroup.Spacings.Add(30.0); ->then it works
           CurvedRebarGroup.ExcludeType = BaseRebarGroup.ExcludeTypeEnum.EXCLUDE_TYPE_NONE;
           CurvedRebarGroup.Name = "RebarGroup";
           CurvedRebarGroup.Class = 3;
           CurvedRebarGroup.Size = "8";
           CurvedRebarGroup.NumberingSeries.StartNumber = 0;
           CurvedRebarGroup.NumberingSeries.Prefix = "Group";
           CurvedRebarGroup.Grade = "A500HW";
           CurvedRebarGroup.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next