WeldMarkWeldMarkAttributes Class

The WeldMarkAttributes class is the attributes class for the weld mark attributes.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingWeldMarkWeldMarkAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class WeldMarkAttributes : AttributesBase

The WeldMarkWeldMarkAttributes type exposes the following members.

Constructors
  NameDescription
Public methodWeldMarkWeldMarkAttributes
Creates a new default weld mark attributes instance that loads standard attributes.
Public methodWeldMarkWeldMarkAttributes(String)
Creates a new weld mark attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyCustomPresentation
Custom presentation GUID to be applied to the object type
Public propertyFont
The weld mark font settings.
Public propertySeamAbove
The visibility of the seam above parameters.
Public propertySeamBelow
The visibility of the seam below parameters.
Public propertyShowEdgeAround
Gets or sets visibility of the weld mark edge/around property.
Public propertyShowReferenceText
Gets or sets visibility of the weld mark reference text.
Public propertyShowWeldNumber
The visibility of the weld number.
Public propertyShowWorkshopSite
Gets or sets visibility of the weld mark workshop/site property.
Public propertyTransparentBackground
Controls the text background transparency (transparent/opaque).
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next