ClosedGraphicObjectClosedGraphicObjectAttributes Class

The ClosedGraphicObjectAttributes class is the attributes class for the closed graphic object.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class ClosedGraphicObjectAttributes : GraphicObjectGraphicObjectAttributes

The ClosedGraphicObjectClosedGraphicObjectAttributes type exposes the following members.

Properties
  NameDescription
Public propertyBehindModelObjects
Gets or sets whether the closed graphic object is drawn behind model objects
Public propertyHatch
The hatch attributes of the closed graphic object (the closed graphic object is hatchable).
Public propertyLine
The line attributes of the graphic object. A graphic object always consists of lines.
(Inherited from GraphicObjectGraphicObjectAttributes.)
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Inherited from AttributesBase.)
Public methodLoadAttributes
Loads the attributes from the specified file.
(Inherited from AttributesBase.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next