ControlCircle Class

The ControlCircle class defines a user defined (not magnetic) circle helping in modeling work. If there are duplicated input points or 3 input points are in a line, ControlCircle.Insert() will return false. ControlCircle.Select() will return the center point of the circle to Point1.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ControlCircle : ModelObject

The ControlCircle type exposes the following members.

Constructors
  NameDescription
Public methodControlCircle
Initializes a new instance of the ControlCircle class.

The default values are as follows:

  • Color = ControlCircleColorEnum.YELLOW;
  • Extension = 0.0;
Public methodControlCircle(Point, Point, Point)
Initializes a new instance of the ControlCircle class. The control circle is not magnetic.
Top
Properties
  NameDescription
Public propertyColor
Gets or sets the color of the control circle.
Public propertyExtension
Gets or sets the extension of the control circle.
Public propertyLineType
The line type of the control circle.
Public propertyPoint1
Gets or sets the first point. Point1 becomes the center point of the circle after selecting the control circle.
Public propertyPoint2
Gets or sets the second point. Point2 contains the original input Point1 after selecting the control circle.
Public propertyPoint3
Gets or sets the third point. Point3 contains the calculated result from the orthogonal point and the center point after selecting the control circle.
Top
Methods
  NameDescription
Public methodDelete
Deletes the control circle with the given Identifier.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the control circle into the model.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the control circle with the given Identifier.
(Overrides ModelObjectModify.)
Public methodSelect
Selects the control circle with the given Identifier.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point p1 = new Point(4500, 4500, 0);
           Point p2 = new Point(4500, 9000, 0);
           Point p3 = new Point(0, 0, 0);
           ControlCircle controlCircle = new ControlCirle(p1, p2, p3);

           bool Result = false;
           Result = ControlCircle.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next