SpiralBeamErrorStatus Enumeration

Define possible statuses for geometry creation/modification commands.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public enum ErrorStatus
Members
  Member nameValueDescription
DataMissing0 Status when some part data is missing.
DefinitionPointsTooClose1 Status when definition points are too close.
DefinitionPointsCannotBeAligned2 Status when definition points are on line with sweep direction.
ZeroTotalRiseWithMore360Degrees3 Status when total rise is zero and rotation angle more than 360 degrees.
RotationAngleIs0Degrees4 Status when rotation angle is 0 degrees.
InvalidGeometry5 Status when helix has invalid geometry.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next