Identifier Class

The Identifier class represents an identifier that holds information about the identifier number of an object.
Inheritance Hierarchy
SystemObject
  Tekla.StructuresIdentifier

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Identifier

The Identifier type exposes the following members.

Constructors
  NameDescription
Public methodIdentifier
Constructs an empty identifier.
Public methodIdentifier(Guid)
Constructs an identifier with the given GUID.
Public methodIdentifier(Int32)
Constructs an identifier with the given ID.
Public methodIdentifier(String)
Constructs an identifier with the given GUID string.
Top
Properties
  NameDescription
Public propertyGUID
The object's globally unique identifier. If the GUID value is set manually, the ID is initialized to 0 and the identification is done based on the GUID.
Public propertyID
The identifier number. If the ID value is set manually, the GUID is initialized to Guid.Empty and the identification is done based on the ID.
Public propertyID2
The sub identifier number. If the subID value is set manually, the GUID is initialized to Guid.Empty and the identification is done based on the ID.
Top
Methods
  NameDescription
Public methodEquals(Object)
Compares the identifier with another object instance.
(Overrides ObjectEquals(Object).)
Public methodEquals(Identifier)
Compares the identifier with another identifier instance.
Public methodGetHashCode
Gets the hash number of the identifier.
(Overrides ObjectGetHashCode.)
Public methodIsValid
Returns true if the identifier seems to be valid. The validation is done based on the ID or GUID property.
Public methodToString
Returns the integer ID as a string.
(Overrides ObjectToString.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next