Settings Class

The Settings class contains the currently active unit settings.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DatatypeSettings

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
public class Settings

The Settings type exposes the following members.

Constructors
  NameDescription
Public methodSettings
Initializes a new instance of the Settings class
Top
Methods
  NameDescription
Public methodStatic memberGetValue
Gets the value of the setting with the given name.
Public methodStatic memberSetValue
Sets a setting to a value.
Public methodStatic memberTryGetValue(String, Object)
Tries to get the value of the setting with the given name.
Public methodStatic memberTryGetValueT(String, T)
Tries to get the value of the setting with the given name and given object type.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next