MatrixFactoryRotate Method

Returns a rotation matrix in a Clockwise rotation around the given rotation axis, defined by the given angle and the given rotation axis.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public static Matrix Rotate(
	double Angle,
	Vector Axis
)

Parameters

Angle
Type: SystemDouble
The rotation angle (in radians).
Axis
Type: Tekla.Structures.Geometry3dVector
The rotation axis.

Return Value

Type: Matrix
The new rotation matrix.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next