RebarItem Class

The RebarItem class contains information from the rebars in the catalog (rebar_database.inp).
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsRebarItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarItem

The RebarItem type exposes the following members.

Constructors
  NameDescription
Public methodRebarItem
Creates a new rebar item instance.
Top
Properties
  NameDescription
Public propertyActualDiameter
The rebar item's actual diameter.
Public propertyBendRadius
The rebar item's bending radius.
Public propertyCode
The rebar item's code.
Public propertyCrankedLength
Gets or sets the cranked length.
Public propertyCrankedLengthType
Gets or sets the cranked length type.
Public propertyCrankExtraOffset
Gets or sets the crank extra offset.
Public propertyCrankStraightLength
Gets or sets the crank straight length.
Public propertyCrossSectionArea
The rebar item's cross section area.
Public propertyCurveTolerance
Gets or sets the curve tolerance.
Public propertyExtraPointShortening
Gets or sets the extra point shortening.
Public propertyGrade
The rebar item's grade.
Public propertyHookLength135Degrees
The rebar item's hook length for 135 degrees.
Public propertyHookLength180Degrees
The rebar item's hook length for 180 degrees.
Public propertyHookLength90Degrees
The rebar item's hook length for 90 degrees.
Public propertyHookRadius135Degrees
The rebar item's hook radius for 135 degrees.
Public propertyHookRadius180Degrees
The rebar item's hook radius for 180 degrees.
Public propertyHookRadius90Degrees
The rebar item's hook radius for 90 degrees.
Public propertyLapLength
Gets or sets the lap length.
Public propertyMaxRadiusRequiringBending
Gets or sets the max radius requiring bending.
Public propertyNominalDiameter
The rebar item's nominal diameter.
Public propertySize
The rebar item's size.
Public propertyUsage
The rebar item's usage.
Public propertyWeightPerLenght
The rebar item's weight per lenght.
Top
Methods
  NameDescription
Public methodDelete
Deletes the rebar item from the rebar database.
Public methodCode exampleExport
Exports the rebar item in the catlog to given file name. If path is not given rebar is exported to model folder. If filename is empty rebar name is used as filename.
Public methodInsert
Inserts the rebar item in the rebar database.
Public methodModify
Modifies the rebar item in the rebar database based on the given parameters.
Public methodSelect(String, String)
Selects the rebar item in the rebar database.
Public methodSelect(String, Double, Boolean)
Selects the rebar item in the rebar database.
Public methodSelect(String, String, Double)
Selects the rebar item in the rebar database.
Public methodSelect(String, String, String)
Selects the rebar item in the rebar database.
Public methodSelect(String, Double, Double, Boolean)
Selects the rebar item in the rebar database.
Public methodSelect(String, Double, String, Boolean)
Selects the rebar item in the rebar database.
Top
Fields
  NameDescription
Public fieldStatic memberDIAGONAL_DISTANCE_STRING
The diagonal distance string.
Public fieldStatic memberDIAGONAL_RATIO_STRING
The diagonal ratio string.
Public fieldStatic memberHORIZONTAL_DISTANCE_STRING
The horizontal distance string.
Public fieldStatic memberHORIZONTAL_RATIO_STRING
The horizontal ratio string.
Public fieldStatic memberMAIN_USAGE
The main usage string.
Public fieldStatic memberTIE_STIRRUP_USAGE
The tie/stirrup usage string.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next