GuidConversion Class

Conversion of old TS GUIDs to current GUIDs. GUIDs are changed in TS save as operation, this class can be used to convert old GUIDs to current GUIDs. To recognize the need for GUID conversion, application needs to save project GUID and compare to the current project GUID. Note: With big models the instance uses a lot of memory.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.OperationsGuidConversion

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public class GuidConversion

The GuidConversion type exposes the following members.

Constructors
  NameDescription
Public methodGuidConversion
Initializes a new instance of the GuidConversion class.
Top
Methods
  NameDescription
Public methodGetGuidMapping
Gets the GUID mapping.
Public methodGetNewGuid
Gets the new GUID.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next