PropertyElement Class

The PropertyElement class may represent any of the many different mark element types, such as the profile, the material and the name. The property is defined by the name and it is converted into a textual value before the mark is drawn.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class PropertyElement : ElementBase

The PropertyElement type exposes the following members.

Constructors
  NameDescription
Public methodPropertyElement
Creates a new property element instance with the given property element type.
Top
Properties
  NameDescription
Public propertyFont
The font of the property.
Public propertyName
The property name.
Public propertyPropertyType
The type of the property element.
Public propertyValue
The current value of the property.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next