Contour Class

The Contour class defines a possibly chamfered contour. Contours must not have loops.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelContour

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Contour

The Contour type exposes the following members.

Constructors
  NameDescription
Public methodContour
Instantiates an empty contour.
Top
Properties
  NameDescription
Public propertyContourPoints
The contour points belonging to the contour.
Top
Methods
  NameDescription
Public methodAddContourPoint
Adds a new contour point to the contour. Do not add the same contour point twice.
Public methodCalculatePolygon
Calculate a polygon approximating the contour with chamfers evaluated.
Public methodGetPolycurve
Gets the contour geometry as Polycurve
Top
Fields
  NameDescription
Public fieldStatic memberMAX_CONTOUR_POINTS
The maximum number of contour points that is typically valid in Tekla Structures.
Public fieldStatic memberMIN_CONTOUR_POINTS
The minimum number of contour points that is typically valid in Tekla Structures.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next