OBBClosestPointTo Method (Point)

Calculates the closest point in OBB to given point.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public Point ClosestPointTo(
	Point point
)

Parameters

point
Type: Tekla.Structures.Geometry3dPoint
Point to calculate against.

Return Value

Type: Point
Closest point in OBB to given point.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the point parameter.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next