WpfShapeCatalog Class

The WpfShapeCatalog class represents a group of controls to select shapes using the shape catalog.
WpfShapeCatalog
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class WpfShapeCatalog : UserControl, 
	IComponentConnector

The WpfShapeCatalog type exposes the following members.

Constructors
  NameDescription
Public methodWpfShapeCatalog
Initializes a new instance of the ShapeCatalog class.
Public methodWpfShapeCatalog(String)
Initializes a new instance of the ShapeCatalog class and will select the Shape (if available) in the tree.
Top
Properties
  NameDescription
Public propertyButtonHeight
Gets and sets the height of the button control.
Public propertyButtonText
Gets and sets the text of the button control.
Public propertyButtonWidth
Gets and sets the width of the button control.
Public propertySelectedShape
Gets or sets the selected Shape in the control.
Top
Methods
  NameDescription
Public methodInitializeComponent
InitializeComponent
Public methodOnValueChanged
Event handler for passing generic catalog data back to dialog
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the selection has been done.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next